How do you deal with this problem? (layering issue)

View previous topic View next topic Go down

How do you deal with this problem? (layering issue)

Post  Cosmo on Fri Jan 27, 2017 4:55 am

Hey, i have encountered this problem before, and i am getting such a problem again. I didn't used to have this, but for whatever reason, somewhere down the line, my maker decided that, if i make a level, the background layers do not show up like how i not only tell it to, but, during testing, they do not show up like they do in the maker preview. In the preview, according to how i have it set, things are in place, but when i try it, certain things aren't showing up despite me setting the Z building thing correctly and having it show in the preview pic within maker, the water layers aren't showing up correctly, the clouds, despite being moved to the top, are at the bottom and on the floor, and there is black space left in, leaving in unwanted after images. If anyone has had this problem before, and knows how to deal with it, please let me know how.


Last edited by Cosmo on Fri May 05, 2017 5:31 am; edited 1 time in total
avatar
Cosmo
Galsia

Posts : 35
Join date : 2013-01-16

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  oracle on Wed Mar 01, 2017 3:06 pm

Cosmo wrote:If anyone has had this problem before, and knows how to deal with it, please let me know how.

You may need to post the fpg and smk somewhere so that someone can give a look. Or maybe some screenshots
avatar
oracle
Signal

Posts : 120
Join date : 2015-11-14
Location : Brazil

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  Cosmo on Tue Mar 14, 2017 2:43 am

I'll start off showing screenshots, but i will resort to sending the fpg and whatnot if i have to.




As you can see, judging by this, everything should appear during testing/playthrough as indicated, but whenever i do so, it shows up like this.



I have never had this issue before. Heck, when i go back to older fpgs that work and modify them, they still tend to show up ok even if modded. But for whatever reason, it seems to not care for me doing new ones. I have looked at the older ones, and i use the same methods for them as i have here, but for whatever reason, they do not arrive at the same results.

avatar
Cosmo
Galsia

Posts : 35
Join date : 2013-01-16

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  oracle on Tue Mar 14, 2017 3:01 pm

Cosmo wrote:I'll start off showing screenshots, but i will resort to sending the fpg and whatnot if i have to.

I'm lost. Please send the fpg and smk Razz
avatar
oracle
Signal

Posts : 120
Join date : 2015-11-14
Location : Brazil

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  Cosmo on Tue Mar 14, 2017 10:20 pm

Very well. I wanted to at least see if i could do it without having to resort to this. But it seems this is the only way.

fpg
smk


Last edited by Cosmo on Tue Mar 14, 2017 11:23 pm; edited 1 time in total
avatar
Cosmo
Galsia

Posts : 35
Join date : 2013-01-16

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  oracle on Tue Mar 14, 2017 11:13 pm

Cosmo wrote:Very well. I wanted to at least see if i could do it without having to resort to this. But it seems this is the only way.

fpg
smk

Wrong link for the smk one


Last edited by oracle on Tue Mar 14, 2017 11:26 pm; edited 2 times in total
avatar
oracle
Signal

Posts : 120
Join date : 2015-11-14
Location : Brazil

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  Cosmo on Tue Mar 14, 2017 11:24 pm

Fixed. Link updated.
avatar
Cosmo
Galsia

Posts : 35
Join date : 2013-01-16

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  oracle on Tue Mar 14, 2017 11:26 pm

Cosmo wrote:Fixed. Link updated.

Hey, you have a 001 within the fpg with non-standard size of 1110x80. Not sure if this works. I think it expects at least 1110x240
avatar
oracle
Signal

Posts : 120
Join date : 2015-11-14
Location : Brazil

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  Cosmo on Tue Mar 14, 2017 11:30 pm

Hm. That could have a bit to do with it. It is possible my previous ones were me getting it right and my more recent couple ones were me not doing quite as well. I don't know if i ended up forgetting something, or it just turned out i was doing it correctly then stopped while not even realizing it.
avatar
Cosmo
Galsia

Posts : 35
Join date : 2013-01-16

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  oracle on Wed Mar 15, 2017 8:59 pm

Cosmo wrote:Hm. That could have a bit to do with it. It is possible my previous ones were me getting it right and my more recent couple ones were me not doing quite as well. I don't know if i ended up forgetting something, or it just turned out i was doing it correctly then stopped while not even realizing it.

I just updated it with the 1110x240 size and everything is fine! Razz



From a SORMaker tutorial documentation:

Code:
starting from 320x240, main layer is mandatory.

Format examples :
1024x240 horitzontal scroll
1024x250 Improved horitzontal scroll
1024x260 boat
1024x280 Free camera movement for up/down
1024x480 diagonal scroll
320x1024 elevator
avatar
oracle
Signal

Posts : 120
Join date : 2015-11-14
Location : Brazil

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  Cosmo on Wed Mar 15, 2017 9:43 pm

Ok. Thanks a ton for that. Now i know it's not just my maker screwing up or deciding to be a moron. Now i know i can continue to experiment and have fun with it without it feeling like it has to throw a monkey fit on me. Very Happy
avatar
Cosmo
Galsia

Posts : 35
Join date : 2013-01-16

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  Cosmo on Thu Mar 16, 2017 1:44 am

Maybe i spoke too soon. I go and try it again. I even redo everything, i alter the base to the required limit, i delete all layers and add them back in, i even deleted the smk so i could start over, i redo the layer, and it shows up correctly in the scroll preview. Now everything does show up during testing, the thing is, several things remain misplaced. There are black gaps in places there are not in the scroll preview, i mess with the transparency/opacy, and it either makes it not as bad or worse, never just right, and the city background is either misplaced, or something with the sky is leaving a black gap. To demonstrate, i took a photo consisting of the preview and a small shot in the photo showing how it should appear.



Let me know if i might need to send the fpg/smk again here.

Also, and you can chalk this up to my pure dumbfuckery, but i am confused about the size thing because some of my scroll layers consist of a size much greater than 1024, and many of them worked just fine without anything being misplaced.

On a similar note, i did manage to fix one broken fpg file, i might be able to do others, but that is one i did so far, but that are because i made the floor layers nothing but the floor, and i forgot you have to include a black background, or rather that is what i was doing in the past. So i did fix this one as well with the same thing, and even altered the size to 1024, but for whatever reason, things are being misplaced.

UPDATE: In case you see this, do you think maybe we ought to take this to the chatbox so we can talk things out better?
avatar
Cosmo
Galsia

Posts : 35
Join date : 2013-01-16

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  oracle on Thu Mar 16, 2017 12:17 pm

Cosmo wrote:So i did fix this one as well with the same thing, and even altered the size to 1024, but for whatever reason, things are being misplaced.

Here is the fix - I just changed 001 and I don't see any black gaps:
Code:
https://mega.nz/#!2JZDyLZA!xak8_lDK3_Youu61vjAiqtRjddrer_YHE2NhJnrGeQw

There is no need to change the width to 1024 - the width you used (1110) is OK as long as the height is at least 240 Razz
avatar
oracle
Signal

Posts : 120
Join date : 2015-11-14
Location : Brazil

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  Cosmo on Fri Mar 17, 2017 2:09 am

I'm either ditzy as hell, or i need glasses, cause i could have sworn it said 240. Nevertheless i am going to try, and i will see what happens, then update you on the process.

Ok, perfect. Thanks. I usually compare the size to what's given in the preview, but i must have forgotten to do that this time around. I now know i made the mistake twice of using a floor without a black background before, not sure why, but whatever, i didn't used to, but i guess that's the price to pay when not using it. Whatever, i am a moron when it comes to this it seems, so don't mind me. Razz Just gotta point out whatever i ask in the future i suppose.
avatar
Cosmo
Galsia

Posts : 35
Join date : 2013-01-16

Back to top Go down

Re: How do you deal with this problem? (layering issue)

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum